在Ubuntu、Linux Mint、Debian上通过PPA仓库安装Oracle Java 9

 

鉴于我已经收到太多这样的要求,现在你可以在所有受支持的Ubuntu / Linux Mint的版本中用WebUpd8的Oracle Java PPA仓库来安装最新的Java 9(早期发行版本)。

目前你应该继续使用Java 8,因为Java 9目前只是一个早期发行版本(或许会在2016年发行)!而且Java 9可能含有Bug并且可能不包含最新的安全补丁,你应该在明确需要它的时候再使用。此外,在JDK9中会移除一些Java选项,所以你可能会在各种Java程序中遇到兼容性问题。

提醒:因为不被Oracle Java许可,WebUpd8的Oracle Java PPA仓库不包括任何Oracle Java二进制文件,这就是为什么PPA只提供一个会自动下载最新Java 9(JDK9和Java 9浏览器插件)并为你设置一切的安装程序。此外,Java 9安装程序可以被认为是alpha版,不提供任何质量上的保证,所以使用它需要您自担风险!

同样值得一提的是,Java 9下载服务器是相当缓慢的。所以即便有快速的互联网连接,下载同样可能需要一段时间,甚至会失败(所以你需要再试一次),对此我也没有办法。

如果你想安装Java 8(被认为是稳定版),看这些文章:

通过PPA在Ubuntu中、Linux Mint或着Debian中安装Oracle Java 9(JDK9)

要在所有支持的Ubuntu / Linux Mint中添加Oracle Java PPA源并安装Java 9(注:目前还不支持ARM),请使用以下命令:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java9-installer
要在Debian中安装Java 9 ,你可以像上面一样设置“add-apt-repository”。
提示:如 果你在一个防火墙/路由器后并且阻止了某些下载Java文件所需的重定向,你可以手动下载JDK的tar.gz文件,并将其放置在/var/cache /oracle-jdk9-installer下 – 那么,安装程序将使用本地文件,而不会试图自行去下载存档。安装后,您可以在终端中运行”java -version”来检查Java版本,它的输出应该会类似于这样:
andrei@andrei-desktop:~$   java -version
<b>java version "1.9.0-ea"</b>
Java(TM) SE Runtime Environment (build <b>1.9.0-ea-b50</b>)
Java HotSpot(TM) 64-Bit Server VM (build 1.9.0-ea-b50, mixed mode)

或者,使用“javac -version”:

andrei@andrei-desktop:~$   javac -version
javac 1.9.0-ea

如此类推。

自动安装(自动接受协议)

在继续安装前,Java 9安装程序会提示您接受Oracle的协议,它只需接受一次,所以你不必在每一次更新时重复接受。如果你想让安装自动执行,可以使用下面的命令来自动接受Java 9协议

echo oracle-java9-installer shared/accepted-oracle-license-v1-1 select true | sudo /usr/bin/debconf-set-selections

设置Java环境变量

要自动设置Java 9的环境变量,您可以安装以下包:

sudo apt-get install oracle-java9-set-default

如果您安装过oracle-java7-set-default或oracle-java8-set-default,在安装oracle-java9-set-default时他们将被移除(并且环境变量也都会被取而代之变为对于Java9的设置)

原文链接: bestubuntu 翻译: ImportNew.com - 吴 鹏煜
译文链接: http://www.importnew.com/15234.html
[ 转载请保留原文出处、译者和译文链接。]

关于作者: 吴 鹏煜

(新浪微博:@Nappp

查看吴 鹏煜的更多文章 >>



相关文章

发表评论

Comment form

(*) 表示必填项

还没有评论。

跳到底部
返回顶部